2
\$\begingroup\$

It's about this suggested edit I made, and the suggestion to create a new answer to the question.

In this case, the change I made from IList<> to IEnumerable<> on the private methods was only to fix a compilation problem, so that I could move the .ToList() call to another position, which most likely improved performance.

This is in the discussion (the question asked by that poster) a little minor and I thought it was not worthy of a new answer. And since I don't have enough rep to add a comment to the answer, there is not really another way to add this information to the answer.

Is there a clear answer as to why this was rejected (i.e. the guidelines to edit, or repost an answer with some edits)?

\$\endgroup\$
0
\$\begingroup\$

My apologies. I mistook that you were trying to edit the question not an answer. I don't know if it is possible to withdraw a rejection, I am looking, but if you resubmit (copy and paste from history), I will approve this time. Again, sorry for the confusion.

Edit

I'm not really having any luck in finding a way to undo my rejection. Its either not possible, not available to me, or is really obscure. Google isn't helping either. I will give you the chance to resubmit the edit so that you get credit, but if you take no action after a day I'll fix it. Again, sorry for the misunderstanding.

\$\endgroup\$
  • \$\begingroup\$ Ok thank you. I have read other topics like this one by now and I understand how it happened. One question before I resubmit: Should I keep the bold edit section in my edit, it might clarify or just be extra garbage in the answer, what do you think? \$\endgroup\$ – JorisG Oct 12 '12 at 14:14
  • \$\begingroup\$ @JorisG: I think its a good idea to clarify that you made an edit and where. Otherwise it may go unnoticed. \$\endgroup\$ – mseancole Oct 12 '12 at 14:18
  • \$\begingroup\$ Ok thank you for the insight, I just reposted the edit. \$\endgroup\$ – JorisG Oct 12 '12 at 14:19
  • \$\begingroup\$ I'm assuming it takes a few minutes for it to show up, so just in case you are wondering why I haven't accepted it yet, its because I haven't seen it yet. \$\endgroup\$ – mseancole Oct 12 '12 at 14:28
  • \$\begingroup\$ I don't know, it seems to me that it should be in the queue. It shows on the page that the edit is in peer review, and I can see that there is one suggested edit in the queue. But as I have not enough rep, I can't see if it is my suggested edit that is in the queue... \$\endgroup\$ – JorisG Oct 12 '12 at 14:51
  • \$\begingroup\$ Well now... this is just odd... After your last comment I decided to investigate. Normally when a new edit is available it shows up on the top bar in a little bubble with a number showing how many are in queue. This time there were none, but when I manually checked I noticed a couple. So I proceed to approve your edit, but it just refreshes the page and nothing happens except that its asking me to approve your edit again. I checked the answer and it remains unedited. I don't know what's going on. \$\endgroup\$ – mseancole Oct 12 '12 at 15:08
  • \$\begingroup\$ And it just now displayed properly and worked. So, I don't know what happened, but it should be edited now. Sorry for the confusion. \$\endgroup\$ – mseancole Oct 12 '12 at 15:10
  • \$\begingroup\$ ok perfect this can be closed for me. Which I don't know how todo, nor to ask for :( \$\endgroup\$ – JorisG Oct 12 '12 at 15:19
  • \$\begingroup\$ That's unnecessary. You've marked it answered, which means the problem has been solved. \$\endgroup\$ – mseancole Oct 12 '12 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .