I cannot see any bold and and italic text on Code Review.

It started a few weeks ago on on machine with Chrome and now the same happens in Opera and Edge on another machine. And this is not only inside the editor but everywhere, comments, flags, moderator tools. No bold and italic text anywhere.

This is how this question looks on Code Review:

enter image description here

This is how the same question looks on Stack Overflow:

enter image description here

Have any one experienced a similar problem? Is this some kind for a Code Review disease? I have now clue what happened. I could understand it if I had installed some new extensions but I have none in Edge and it also does not show any formattings.

  • \$\begingroup\$ no repro, Chrome 63.0.3239.84 (64 bits). \$\endgroup\$ Commented Dec 20, 2017 at 17:30
  • 1
    \$\begingroup\$ I have the same issue, also Chrome63.0.3239.84 \$\endgroup\$
    – Ludisposed
    Commented Dec 20, 2017 at 17:35
  • \$\begingroup\$ @Mat'sMug thx for checking. This is really strage. I don't know what I did to my two computers. Chrome, Opera, Edge, IE, none of them renders these two formattings. There is Win 8 on one machine and Win 10 on another. They are completely different configurations. \$\endgroup\$
    – t3chb0t
    Commented Dec 20, 2017 at 17:35
  • \$\begingroup\$ @Ludisposed it's good to know that I'm not alone with that ;-) \$\endgroup\$
    – t3chb0t
    Commented Dec 20, 2017 at 17:36
  • \$\begingroup\$ I'm pretty sure that the reason is within your system fonts. CR has a non-typical font. Sometimes your fallback font does not support bold / italic \$\endgroup\$
    – Vogel612
    Commented Dec 20, 2017 at 17:37
  • \$\begingroup\$ @Vogel612 I looks like you're right about the font. I did install Open Sans some time ago and I see it's the first one on the font-family: 'Open Sans','Helvetica Neue',Helvetica,Arial,sans-serif;. It seems to not have a bold faces. If I disable this style the formatting comes back. Although the formatting works correctly in MS Word when I use the bold face :-| \$\endgroup\$
    – t3chb0t
    Commented Dec 20, 2017 at 17:46
  • 1
    \$\begingroup\$ @Vogel612 Whilst the fonts we have installed don't have bold or italics, it's a problem with SE's CSS that it's not falling back to the correct font. \$\endgroup\$
    – Peilonrayz Mod
    Commented Dec 20, 2017 at 18:13
  • \$\begingroup\$ @Peilonrayz I've added a item to FontSubstitutes in the registry that should try to map Open Sans to Open Sans Regular but I guess I need to restart my PC and now it's not a convenient time ;-] I'll check that later. \$\endgroup\$
    – t3chb0t
    Commented Dec 20, 2017 at 18:22
  • \$\begingroup\$ @t3chb0t IIRC the problem is the browser sees the font, but doesn't know it's without the bold or italics. And so won't download the missing font from SE. \$\endgroup\$
    – Peilonrayz Mod
    Commented Dec 20, 2017 at 19:12
  • \$\begingroup\$ @Peilonrayz how do i fix that though? \$\endgroup\$ Commented Dec 28, 2017 at 23:03


Browse other questions tagged .