Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [bug]

Indicates you've found an erroneous or unexpected behaviour in the system that needs to be fixed.

2
votes
0answers
44 views

Active bounties image is not loaded

Today whilst scrolling CodeReview, I came across this broken image. Seems the Active Bounties image is not working properly anymore.
5
votes
1answer
46 views

Python 2.x merger bugs

After the creation of the Python-2.x tag there are a couple of bugs: The 'top users' page now doesn't show the correct information. My profile shows the tag as Python-2.7. The Python-2.x badge page ...
5
votes
1answer
41 views

Odd formatting bug in display of assembly code

I hit an odd, though not critical bug in the display of assembly language code on the question Disassembler for intel 8080. There's a block of assembly code where the format is: ...
3
votes
0answers
38 views

Inapplicable help page [duplicate]

This page (Can I support my product on this site) is Stack Overflow's corresponding help page with names exchanged - saying "Code Review" instead of "Stack Overflow". It doesn't belong here. This page ...
6
votes
3answers
113 views

Mathjax formatting missing in rendered output of suggested edit

While reviewing a suggested edit, I observed that the Mathjax formatting was not respected in the rendered output view (see screenshot below). Shouldn't the Mathjax formatting be displayed like it ...
5
votes
1answer
52 views

Formatted C++ code is outdated for current standard

I don't know how it was decided which language to use when coloring the code blocks, but (on the main site) I assume it figured out it was C++ since it generally works OK. But, this line broke it. It ...
3
votes
1answer
75 views

MathJax tripped for some reason on the search page

A question posted by another user has somehow triggered MathJax on the search page, but only when searching for the user and the tag that is on the question that is posted. Go to search and type in <...
6
votes
1answer
80 views

Nav bar? Where are you?

Why is the top navigation bar not fixed to the top? When I scroll down, I can't see it. But, on Stack Overflow, the navigation bar is fixed to the top and can be seen even after scrolling down. Any ...
3
votes
0answers
37 views

Relative day of election start is wrong saying 'yesterday' instead of '2 days ago'

The election page lists the various phases in the right margin, including when those phases start/started. Currently the UTC time is 2018-04-04 14:35 and the ...
2
votes
3answers
40 views

I think there is a bug with the duck thingy

I think there is a bug with the duck thingy, when I click on it, then click on 'no' the popup still pops up telling me its listening. Is this a bug, or is it on purpose?
7
votes
1answer
56 views

How has an on-hold question been answered?

I am curious to know how come this question was answered 8 minutes after it has been put on hold... normally, you cannot answer such questions.
3
votes
1answer
27 views

Favorite categories - not all favorite tag questions are colored

In my favorite tags section I have python, python-2.7 and python-3.x. When searching for specific questions containing, say, python I don't have all of the questions colored. Should this happen? Do I ...
11
votes
0answers
41 views

For actions in a user profile more than a year ago the year should be visible

When viewing a user profile for a mostly inactive user (For example, akmad), the activity displayed goes back multiple years, but there is no year value for "ancient" activities and it does not make ...
0
votes
0answers
31 views

Emphasis doesn't work correctly with comments at SE Code Review [duplicate]

I've noticed that the markdown emphasis (_emphasized text_) doesn't seem to render correctly at SE Code Review (comments). Example markdown: ...
5
votes
1answer
190 views

Why does the Community bot have 5 reputation?

The community bot has 5 reputation: why is this? Also, its Main User has 1 reputation, and only the Meta user has 5 reputation, which doesn't usually happen; even with people. Is this a bug?
3
votes
0answers
36 views

Why can't I see any bold and italic text on Code Review? [duplicate]

I cannot see any bold and and italic text on Code Review. It started a few weeks ago on on machine with Chrome and now the same happens in Opera and Edge on another machine. And this is not only ...
1
vote
1answer
53 views

Why can't I create a 50 rep bounty?

I want to make a bounty on a question and I have seen some questions currently with a 50 rep bounty, but the only option available to me is a 100 rep bounty. I was wondering why.
7
votes
1answer
61 views

Insecure links in custom close reasons should be HTTPS

In the comments on this meta answer, a person said: When I click on your link, Chrome says "Attackers might be trying to steal your information". The link in question was from this quote: ...
2
votes
1answer
35 views

Incorrect automatic Perl regex syntax

Becoming a Perl bandit, in this question I had to escape my regex expression \: to avoid funny syntaxing. Now on my newest Perl question, I encounter the same issue....
7
votes
0answers
82 views

Error about improperly formatted code appears when attempting to format LaTeX as math

In an answer, I tried to post the following math: ...
0
votes
0answers
40 views

Font weights appear indistinguishable [duplicate]

Code Review is the only website on which font weights behave weirdly - for me (using Linux Mint 18.2 and Firefox 55): Some bold text: hello world. ... but it doesn't seem bold! It's the same ...
7
votes
0answers
49 views

Never received notification that an answer to my question was posted

I just happened to look at a question I asked a month ago and noticed that an answer was posted a week after I asked the question. I was surprised to see an answer since I didn't recall ever receiving ...
1
vote
0answers
29 views

Possible “Snippet VM”?

I just recently got a post reopened. I tried out the snippet on there and Chrome said: this site is trying to load unsafe scripts (load unsafe scripts) When I did, it automatically set Code ...
6
votes
1answer
55 views

Code block is required, but the programming language is purely graphical

Your post appears to contain code that is not properly formatted as code. There is no code in my post, only text and links. Here is a link to my question: Limit Drive Starts with Function Block ...
1
vote
0answers
48 views

Firefox don't show formatting - specific for Code Review community [duplicate]

I don't see the bold or italics formatting in the Code Review community in Firefox. In other Stack Exchange communities there is no such problem. (In Chrome I see those types of formatting also in ...
3
votes
0answers
35 views

Insecure Connection error in help page [duplicate]

In the help center page, there is a description below the search box as: For more information, also see posts on Code Review meta tagged with [faq]. When ...
3
votes
1answer
54 views

The help-center contains links to meta.codereview.* instead to codereview.meta.*

See What topics can I ask about here? for example: For more information on this policy, please see this post on our Meta site. A user gets greeted with an "unsecure connection" warning, since the ...
6
votes
1answer
48 views

Can't get the syntax highlighting for Go

The syntax highlighting (for Go) does not seem to be applied for this question: db access wrapper for Go project I tried to apply it manually to my answer (https://codereview.stackexchange.com/a/...
6
votes
0answers
33 views

10k tools on meta do not have latest deletion info

So there's a pretty recent question I knew to be deleted. I'm including a partial screenshot for date-related purposes. Now let's check the moderation tools (where I was hoping to find the question ...
11
votes
2answers
317 views

Font style doesn't work with new font

We seem to have gotten a new font in the last couple of days. This new font family for me is for the most part the below. As most other font-family's use ...
6
votes
1answer
54 views

Setting for tracking a privilege / tag badge overlaps tracker

MacOS: 10.12.5 Safari: 10.1.1 (12603.2.4) Windows: 10.1703.15063.296 Opera: 45.0.2552.881 32-bit Windows: 10.1703.15063.296 Chrome: 58.0.3029.110 64-bit Windows: 10.1703.15063.296 Internet Explorer:...
5
votes
0answers
72 views

What's this 'Bad Gateway' ad?

Now that CR community ads work again, I'm frantically refreshing my browser trying to get to see my Rubberduck ad... In 10 minutes I've seen the Brainduck ad 17 times, but none of my ducky. Is this ...
2
votes
1answer
72 views

python-3.x tag does not pass lang-py to code-prettify

I asked a Python 3 question, and tagged it python-3.x. The highlighting was messed up, because the python-3.x tag wasn't passing the lang-py argument to the JS ...
8
votes
1answer
75 views

External resources make keyboard-nav unusable

Recently (as in, since ads have been enabled), I have intermittently been having trouble with the site. I'm using the keyboard navigation (and moderation) for a significant portion of my activities ...
3
votes
0answers
83 views

An 'edit' might have messed up my ability to edit

Someone edited my answer to 'FFT Algorithm', and after that, I am not able to edit the code. Even if I just open it in edit mode, and try saving (without doing any change), it says: code needs 4 ...
3
votes
0answers
50 views

Bug with empty div container in main site

Noticed this a while back, forgot to say something (I think, could be dupe, no idea), but I have an empty div on my main site view underneath my favourite tags, and ...
9
votes
0answers
91 views

Follow the name change of “Programmers” to “Software Engineering”

In "our" help center there are links to programmers.stackexchange.com. I guess this should be changed to reflect the recent renaming of that site to "Software Engineering".
6
votes
2answers
60 views

The MathJax newline \\ is broken in tag wikis

In an attempt to edit the tag wiki of collatz-sequence I noticed the following strange behaviour. The conjecture is often stated as a definition by cases and even serves as an example for that ...
6
votes
0answers
47 views

Two different errors when joining this site

I'm an old user on this website. I wanted to join the Code Review community just now, so I clicked the "join this community" button on the top navbar, got a page with a fancy blue button so I click to ...
7
votes
0answers
58 views

UI falsely attributes migration to users who merely voted for closure

I voted to close a question today. Nothing new, except the closure turned into an unwanted migration. The question should NOT have been migrated, but all of a sudden my name was on it: I voted to ...
6
votes
1answer
44 views

Receiving badge before the requirements are met

Just a few hours back I received the nice answer badge for this answer of mine which I posted few months back. The nice answer page says that (to receive the badge) : Answer score of 10 or more. ...
5
votes
0answers
60 views

Possible misalignment within mod message page

It appears that various elements are misaligned within the mod message page: I don't remember exactly how it used to look, but I believe the guidelines box (and the message box) should be along the ...
10
votes
0answers
77 views

Sign Up / Log In page header looks funny

The page header for the Sign Up / Log In page looks a little funny: The white Background on the header doesn't match the text. Also it may be debatable whether it's intended to break the background ...
5
votes
0answers
74 views

Line alignment bug with user names and comments

There seems to be a bug in the comments where if the username wraps to the next line and ends up underneath a word that contains characters like 'g' it will overlap those characters see: The image is ...
14
votes
0answers
98 views

Flag summary layout broken

As you see on the picture, flag summary layout is broken. The right column should be on the right, instead of below the left column. This doesn't happen on the other SE sites. Tested on latest ...
5
votes
1answer
51 views

The checkmark for “positive question record” clips a bit

Just noticed this earlier on my Mac, but the checkmark when you click a badge description (i.e. [badge:socratic]) clips a bit. Here's an image for a better description. OS X El Capitan, 10.11.4 ...
11
votes
1answer
66 views

New Answers to Old Questions layout is broken

The "New Answers to Old Questions"-View in the 10k Tools layout is broken:
6
votes
0answers
44 views

Bug in display of recently earned badge

When I go to my profile, on the Activity tab under Badges, I see this: Notice how the badge only has the open bracket {. Now when I scroll down to the badge ...
3
votes
1answer
68 views

The “Edit” screen seems to be broken

I saw an open edit on a question, and when I clicked it I got this: One of the buttons is shown only partly, and I think there are some buttons missing. Browser is Chrome 47.0.2526.111 on Windows 7 (...
9
votes
1answer
73 views

Are community ads ever served?

So community-ads are now activated, and at the time of this writing we have 4 ads meeting the criteria for being served on the sidebar: The stats page is showing each ad's score, creation date and ...